Commit in GeomConverter/src/org/lcsim/geometry/subdetector on RefactorBranch
CalorimeterIDDecoder.java+1-141.4 -> 1.4.2.1
Move utility function to SegmentationBase.

GeomConverter/src/org/lcsim/geometry/subdetector
CalorimeterIDDecoder.java 1.4 -> 1.4.2.1
diff -u -r1.4 -r1.4.2.1
--- CalorimeterIDDecoder.java	24 Aug 2005 07:05:07 -0000	1.4
+++ CalorimeterIDDecoder.java	28 Sep 2005 00:12:30 -0000	1.4.2.1
@@ -11,20 +11,7 @@
     public Calorimeter getCalorimeter()
     {
         return (Calorimeter) getSubdetector();
-    }
-    
-    /**
-     * FIXME: Should be renamed as it is actually returning the distance to the midpoint of the sensitive layer.
-     * FIXME: Belongs here???  Why not just use LayeredSubdetector interface?
-     */
-    public double getDistanceToSensitive(int layer)
-    {
-        if ( detector.getLayering() == null )
-        {
-            throw new RuntimeException("layering is null");
-        }
-        return detector.getLayering().getDistanceToLayerSensorMid(layer);
-    }
+    }   
     
     /* FIXME: Next 3 should be in CellNeighbours (or equiv) interface definition. */
     public long[] getNeighbourIDs(int deltaLayer, int deltaTheta, int deltaPhi)
CVSspam 0.2.8