Print

Print


Hi,

The lcsim version used by hps-java has been changed from 1.24-SNAPSHOT to 1.24, as there is a major update coming soon to lcsim which could possibly introduce incompatibilities and errors.  (The 1.24 lcsim release was made today from the CVS head.  The new lcsim will be tagged as 1.25-SNAPSHOT.)  Specifically, there is a new FreeHep record loop implementation that will be used instead of the old one, and an lcsim branch that uses this is being merged into the CVS trunk, probably by the end of the week.  In order that current hps-java analysis work for the PAC meeting is not adversely affected, we will reference the fixed lcsim release for the time being, instead of the current snapshot.

Consequently, if you introduce new code into lcsim OR GeomConverter while the hps-java POM has this fixed release, it will not show up in your hps-java build.  I anticipate that we will move to the next lcsim snapshot release in a few weeks time, once it has been confirmed that the new lcsim works with hps-java, and following the PAC meeting.  This update will then necessitate that all users of JAS move from the 0.8.x releases to a new Maven-based JAS distribution with 0.9.x version numbers.  I plan to send out a set of basic instructions for getting and configuring the new JAS after this occurs.

Let me know if you have any questions about this.

--Jeremy

########################################################################
Use REPLY-ALL to reply to list

To unsubscribe from the HPS-SOFTWARE list, click the following link:
https://listserv.slac.stanford.edu/cgi-bin/wa?SUBED1=HPS-SOFTWARE&A=1