Print

Print


Hello Stuart,

Yes, you will need the entire set of software to study any of the detector components fully.

SLIC is the simulation engine that simulates our experiment using the GEANT4 libraries. It is an essential component to do Monte Carlo studies of the detector. 

Best,
Maurik

On Oct 11, 2013, at 7:42 AM, Stuart Fegan <[log in to unmask]> wrote:

Hi Everyone,

This seems like a good point to interject with a question (or two) of my own.  I managed to set up the HPS software on my own laptop a few days ago, with a minor hack or two to suit my system (I've yet to update, but I don't foresee any problems).  Eventually, we'd like a central setup on our network here in Genova, similar to what we have for other JLab software, so we can have the ability to farm out more processor-intensive tasks and such like.  Is it worthwhile looking at performing a full install of the all the components, or should we be looking only at a subset relating to our efforts on the ECal?  Any advice would be appreciated.

On a more personal (and probably naive) note, what is the role of SLIC?  It's positioning in the "Installing HPS Software" confluence page after IDE recommendations implies a minor role and, in my very limited exploration of the software, I'm not quite sure where it fits in.

I would have brought these points up during the meeting yesterday, but I was a bit busy and could only listen passively then had to leave before the end, apologies.

Cheers,
Stuart

On 10/11/2013 04:34 AM, Kyle McCarty wrote:
[log in to unmask]" type="cite">
Jeremy,

Thanks for the response. After upgrading as you suggested and rebuilding,everything built correctly. It might be worth updating the confluence page (https://confluence.slac.stanford.edu/display/hpsg/Installing+HPS+Software) telling how to install the software if it will now be necessary to install GeomConverter->lcsim->hps-java, assuming that this isn't just a weird glitch on my end. When that was last updated, hps-java built regardless of whether the other two had been built or not. (I don't have the ability to edit it.)

Thanks for your assistance,

Kyle


On Thu, Oct 10, 2013 at 9:53 PM, McCormick, Jeremy I. <[log in to unmask]> wrote:
Hi, Kyle.

For some reason, your build isn't getting the latest version of GeomConverter which is 2.9-SNAPSHOT.  You need
to install this locally yourself for development by building that package from the CVS head.

You should cvs up your local copies of GeomConverter, lcsim, and hps-java to make sure they are up to date
and then build them in that order e.g.

cd GeomConverter
cvs up -dP
mvn clean install -DskipTests=true

Also do this for lcsim and hps-java.

I bet that will fix the problem, and if it doesn't please let me know what goes wrong.

--Jeremy

-----Original Message-----
From: [log in to unmask] [mailto:[log in to unmask]] On Behalf Of Kyle McCarty
Sent: Thursday, October 10, 2013 6:43 PM
To: hps-software
Subject: hps-java and lcsim Compilation Problems

Hello hps-software,


I was updating to the new version of the HPS software, and I have run into some compilation errors. The modules GeomConverter, hps-detectors, hps-et-java, jevio-base, lcsim-conditions, and lcsim-parent all built correctly without problems. However, hps-java and lcsim both ran into compilation problems. With hps-java, I got the error:

[INFO] -------------------------------------------------------------
[ERROR] COMPILATION ERROR :
[INFO] -------------------------------------------------------------
[ERROR] /net/home/mccaky/hps/hps-java/src/main/java/org/lcsim/hps/conditions/svt/SvtConditionsLoader.java:[7,42] cannot find symbol
  symbol:   class HpsSiSensor
  location: package org.lcsim.detector.tracker.silicon
[ERROR] /net/home/mccaky/hps/hps-java/src/main/java/org/lcsim/hps/conditions/svt/SvtConditionsLoader.java:[93,44] cannot find symbol
  symbol:   class HpsSiSensor
  location: class org.lcsim.hps.conditions.svt.SvtConditionsLoader
[ERROR] /net/home/mccaky/hps/hps-java/src/main/java/org/lcsim/hps/conditions/svt/SvtConditionsLoader.java:[26,14] cannot find symbol
  symbol:   class HpsSiSensor
  location: class org.lcsim.hps.conditions.svt.SvtConditionsLoader
[ERROR] /net/home/mccaky/hps/hps-java/src/main/java/org/lcsim/hps/conditions/svt/SvtConditionsLoader.java:[26,83] cannot find symbol
  symbol:   class HpsSiSensor
  location: class org.lcsim.hps.conditions.svt.SvtConditionsLoader
[ERROR] /net/home/mccaky/hps/hps-java/src/main/java/org/lcsim/hps/conditions/svt/SvtConditionsLoader.java:[30,14] cannot find symbol
  symbol:   class HpsSiSensor
  location: class org.lcsim.hps.conditions.svt.SvtConditionsLoader


It seems something is not working with the SVT conditions classes. Is this a known problem?


For lcsim, the error was

[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 2.191s
[INFO] Finished at: Thu Oct 10 21:28:27 EDT 2013 [INFO] Final Memory: 10M/455M [INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project lcsim: Could not resolve dependencies for project org.lcsim:lcsim:jar:2.12-SNAPSHOT: Could not find artifact org.lcsim:GeomConverter:jar:2.9-SNAPSHOT in lcsim-maven (http://lcsim.org/maven2) -> [Help 1] [ERROR] [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException


It seems that it is having trouble getting the newest version of GeomConverter. Note that lcsim does build if GeomConverter is built first. I'm not sure if this is intentional, but previously I was able to build it successfully without having to build GeomConverter as well. hps-java still gives errors pertaining to SVTConditionLoader even if I compile all the aforementioned modules before it. I can include log files detailing the full output if necessary and this was compiled on "Red Hat Enterprise Linux Server release 5.7 (Tikanga)," if it useful to know.

Thanks,

Kyle


________________________________


Use REPLY-ALL to reply to list

To unsubscribe from the HPS-SOFTWARE list, click the following link:
https://listserv.slac.stanford.edu/cgi-bin/wa?SUBED1=HPS-SOFTWARE&A=1




Use REPLY-ALL to reply to list

To unsubscribe from the HPS-SOFTWARE list, click the following link:
https://listserv.slac.stanford.edu/cgi-bin/wa?SUBED1=HPS-SOFTWARE&A=1



-- 
Stuart Fegan
INFN-Genova
Via Dodecaneso, 33 - 16146, Genova
Italia

E-mail: [log in to unmask]

"perdona il mio italiano - ancora imparando"


Use REPLY-ALL to reply to list

To unsubscribe from the HPS-SOFTWARE list, click the following link:
https://listserv.slac.stanford.edu/cgi-bin/wa?SUBED1=HPS-SOFTWARE&A=1




Use REPLY-ALL to reply to list

To unsubscribe from the HPS-SOFTWARE list, click the following link:
https://listserv.slac.stanford.edu/cgi-bin/wa?SUBED1=HPS-SOFTWARE&A=1