Print

Print


Jacek,

On 03/13/2014 12:44 PM, Becla, Jacek wrote:
> consider renaming modules that deal with a query:
> add "q" in front, e.g., qcontrol (and qmerger?)
They have less to do with "query" and more to do with the czar. Really, 
'control' represents not query control, but the czar's controller 
module. And the merger has to do with merging results. Maybe ccontrol 
and rmerger (czar control and result/row merger).

Which others did you have in mind?


> control
>    - SessionManagerAsync - why not call it AsyncSessionManager
>      (we have AsyncQueryManager not QueryManagerAsync)
SessionManagerAsync is written that way because it's a typedef for 
SessionManager<AsyncQueryManager>.  The fact that we have more than one 
type of SessionManager (and more than one namespace for session ids) is 
a motivation to rethink things. We should either go back to only one 
kind of SessionManager or think of a way to make sure we never get 
confused between different session ids.

AsyncQueryManager is not a template specialization of QueryManager. 
We're going to write a better one that we'll just call "QueryManager". 
The idea of having multiple implementations, benchmarking them, and 
writing up the results as a paper is a ship that has sailed and is not 
likely to return.


>    - thread.cc - pls add description to the header
What you really want is the mess of thread.cc and dispatcher.cc to be 
re-thought and re-designed.

> proto
>    TaskMsgDigest.cc - pls add description to the header
oh, okay. Was there really any confusion? It does only one thing, 
compute a digest of a TaskMsg.


> qproc
>    - testCppParser should be in parser, not qproc
>      (this test needs splitting, right?)
No, testCppParser does not test the parser. Sadly, it is misnamed, much 
like "the new parser" meant much more than just parsing. It tests the 
whole query parsing, analysis, and rewriting framework. Do you have a 
better name? It's an integration test of a few modules.

>    - TaskMsgFactory2 - is that part of ongoing migration
>      from python to c++, or this will stay as is?
You can put in a ticket for eliminating the TaskMsgFactory class in python.

> I understand QueryContext will move from query to qana
> and will become SelectStmtContext plus AnalysisClipboard.
Right, it will get split, and some of it will stay in query, and the 
rest in qana.

-Daniel

########################################################################
Use REPLY-ALL to reply to list

To unsubscribe from the QSERV-L list, click the following link:
https://listserv.slac.stanford.edu/cgi-bin/wa?SUBED1=QSERV-L&A=1