Print

Print


Daniel

That is the thing, they both live in lsst::qserv::xrdfs,
and so if I remove the "fs" around one of them, things
don't compile. I am happy with using the FsFileValidator
name (will you do it or should I?)

Jacek



On 03/27/2014 12:55 PM, Wang, Daniel Liwei wrote:
> Jacek,
>
> On 03/25/2014 09:03 PM, Becla, Jacek wrote:
>> I noticed in xrdfs we have the following pattern:
>>
>> namespace fs {
>> class FileValidator {
>>        virtual void whatever() = 0;
>> };
>> } // end of namespace
>>
>> class FileValidator : public fs::FileValidator {
>>        virtual void whatever() {}
>> };
>>
>> Why not simply:
>>
>> class FileValidatorBase {
>>        virtual void whatever() = 0;
>> };
>>
>> class FileValidator : public FileValidatorBase {
>>        virtual void whatever() {}
>> };
> The "Base" suffix looks ugly to me. Because you've cleaned up the
> namespaces, we don't need "fs" any more because you now have "xrdfs",
> right? The ones in MySqlFs.cc can be FsFileValidator and ChunkInvValidator.
>
> -Daniel
>

########################################################################
Use REPLY-ALL to reply to list

To unsubscribe from the QSERV-L list, click the following link:
https://listserv.slac.stanford.edu/cgi-bin/wa?SUBED1=QSERV-L&A=1