Print

Print


Nevermind this.  The log messages got mixed up somehow,
making me think it was a database issue (maybe due to a
mixture of stderr/stdout?).

-Nathan




On Feb 26, 2015, at 11:59 AM, Nathan Baltzell <[log in to unmask]> wrote:

> I have a new, probably related, error (EvioToLcio, pass1 steering file) :
> 
> 
> 
> FINE: searching for condition ecal_time_shifts in 13 records
> Thu Feb 26 11:55:14 EST 2015 org.hps.conditions.database.DatabaseConditionsManager findConditionsRecords
> INFO: found ConditionsRecord with key ecal_time_shifts
> id: 67
> name: ecal_time_shifts
> runStart: 2000
> runEnd: 9999
> tableName: ecal_time_shifts
> collectionId: 2
> updated: 2014-12-13 20:05:11.0
> created: 2014-11-05 14:46:21.0
> tag: eng_run
> createdBy: jeremym
> notes: dummy time shift values of all 0
> 
> Thu Feb 26 11:55:14 EST 2015 org.hps.conditions.database.DatabaseConditionsManager findConditionsRecords
> FINE: searching for condition ecal_time_shifts in 13 records
> Thu Feb 26 11:55:14 EST 2015 org.hps.conditions.database.DatabasException in thread "main" java.lang.NullPointerException
>    at org.hps.evio.LCSimTestRunEventBuilder.readEvioEvent(LCSimTestRunEventBuilder.java:54)
>        at org.hps.evio.EvioToLcio.run(EvioToLcio.java:420)
>        at org.hps.evio.EvioToLcio.main(EvioToLcio.java:126)
> 
> 
> 
> 
> 
> 
> On Feb 26, 2015, at 3:45 AM, Andrea Celentano <[log in to unmask]> wrote:
> 
>> Hi,
>> yes, it is fixed now.
>> Thanks!
>> Il 02/26/2015 12:03 AM, McCormick, Jeremy I. ha scritto:
>>> Hi,
>>> 
>>> This problem should be fixed now in trunk.
>>> 
>>> The issue was that the EcalChannelCollection was not always properly initialized, so only the one from EcalConditions.getChannelCollection() was actually working properly.  So the channel map was empty in the collection that was being used and the EcalChannel was not being found from the ID on the hit.
>>> 
>>> But now this should happen automatically with some minor changes I made to the conditions system.
>>> 
>>> I didn't need to change your code at all.  It should work as is now.  At least, my testing of your code works now with...
>>> 
>>> java -jar ~/.m2/repository/org/hps/hps-distribution/3.2-SNAPSHOT/hps-distribution-3.2-SNAPSHOT-bin.jar -r /org/hps/steering/users/celentan/LedAnalysis.lcsim -DoutputFile=test -n 100000 -i led_003532.slcio
>>> 
>>> Let me know if this fixes things for you or not.
>>> 
>>> --Jeremy
>>> 
>>> -----Original Message-----
>>> From: Andrea Celentano [mailto:[log in to unmask]]
>>> Sent: Wednesday, February 25, 2015 12:01 PM
>>> To: McCormick, Jeremy I.
>>> Subject: Re: hps-java: connection to the conditions database
>>> 
>>> Hi,
>>> the file is at JLab now, in /scratch/celentan (accessible from farmui)
>>> 
>>>  led_003532.slcio
>>> 
>>> Andrea
>>> On 02/25/2015 07:49 PM, McCormick, Jeremy I. wrote:
>>>> Hi,
>>>> Can you put this LCIO file into your work directory at JLAB so I can download it in order to try and reproduce this?
>>>> --Jeremy
>>>> 
>>>> -----Original Message-----
>>>> From: [log in to unmask]
>>>> [mailto:[log in to unmask]] On Behalf Of Andrea Celentano
>>>> Sent: Wednesday, February 25, 2015 9:02 AM
>>>> To: hps-software
>>>> Subject: hps-java: connection to the conditions database
>>>> 
>>>> Dear all,
>>>> today, after svn up and mvn clean install, I saw that hps-java no
>>>> longer connects to the conditions system. I.e., I am using EXACTLY the
>>>> same command I was using last week, but no connection with the
>>>> database is
>>>> established:
>>>> 
>>>> java -jar
>>>> /local/celentano/eclipse_workspace/hps/distribution/target/hps-distrib
>>>> ution-3.2-SNAPSHOT-bin.jar -r
>>>> /org/hps/steering/users/celentan/LedAnalysis.lcsim -DoutputFile=test
>>>> -n 100000 -i led_003532.slcio
>>>> 
>>>> The output is:
>>>> 
>>>> 
>>>> --- Drivers ---
>>>> org.lcsim.job.EventMarkerDriver
>>>>      eventInterval = 10000
>>>> org.hps.users.celentan.LedAnalysis
>>>> org.lcsim.util.loop.LCIODriver
>>>>      outputFilePath = test
>>>> org.lcsim.job.AidaSaveDriver
>>>>      outputFileName = test.aida
>>>> --- End Drivers ---
>>>> No input files in XML file.
>>>> added SvtSensorSetup to beginning of Driver list LedAnalysis::Detector
>>>> changed was called Feb 25, 2015 5:51:54 PM
>>>> org.lcsim.job.EventMarkerDriver process
>>>> INFO: Event 1 with sequence 0
>>>> java.lang.NullPointerException
>>>>          at org.hps.users.celentan.LedAnalysis.process(LedAnalysis.java:126)
>>>>          at org.lcsim.util.Driver.doProcess(Driver.java:260)
>>>>          at org.lcsim.util.Driver.processChildren(Driver.java:270)
>>>>          at org.lcsim.util.Driver.process(Driver.java:186)
>>>>          at
>>>> org.lcsim.util.DriverAdapter.recordSupplied(DriverAdapter.java:74)
>>>>          at
>>>> org.freehep.record.loop.DefaultRecordLoop.consumeRecord(DefaultRecordLoop.java:832)
>>>>          at
>>>> org.freehep.record.loop.DefaultRecordLoop.loop(DefaultRecordLoop.java:668)
>>>>          at
>>>> org.freehep.record.loop.DefaultRecordLoop.execute(DefaultRecordLoop.java:566)
>>>>          at org.lcsim.util.loop.LCSimLoop.loop(LCSimLoop.java:153)
>>>>          at org.lcsim.job.JobControlManager.run(JobControlManager.java:427)
>>>>          at org.hps.job.JobManager.run(JobManager.java:36)
>>>>          at org.lcsim.job.JobControlManager.run(JobControlManager.java:185)
>>>>          at org.hps.job.JobManager.main(JobManager.java:18)
>>>> 
>>>> 
>>>> where the error refers to the missing conditions.
>>>> 
>>>> Previously, the output was "much more verbose", and I saw the connection to the conditions database being established.
>>>> Can someone explain me if this is normal? Do I have to launch reconstruction in a different way?
>>>> 
>>>> To verify connectivity with the database, I tried:
>>>> mysql -h hpsdb.jlab.org -u hpsuser -p
>>>> 
>>>> I can connect properly to the database and see records..
>>>> 
>>>> Thanks
>>>> Andrea
>>>> 
>>>> ######################################################################
>>>> ##
>>>> Use REPLY-ALL to reply to list
>>>> 
>>>> To unsubscribe from the HPS-SOFTWARE list, click the following link:
>>>> https://listserv.slac.stanford.edu/cgi-bin/wa?SUBED1=HPS-SOFTWARE&A=1
>> 
>> ########################################################################
>> Use REPLY-ALL to reply to list
>> 
>> To unsubscribe from the HPS-SOFTWARE list, click the following link:
>> https://listserv.slac.stanford.edu/cgi-bin/wa?SUBED1=HPS-SOFTWARE&A=1
> 
> ########################################################################
> Use REPLY-ALL to reply to list
> 
> To unsubscribe from the HPS-SOFTWARE list, click the following link:
> https://listserv.slac.stanford.edu/cgi-bin/wa?SUBED1=HPS-SOFTWARE&A=1

########################################################################
Use REPLY-ALL to reply to list

To unsubscribe from the HPS-SOFTWARE list, click the following link:
https://listserv.slac.stanford.edu/cgi-bin/wa?SUBED1=HPS-SOFTWARE&A=1