Print

Print


That error is caused by a bug - if there were no "bias good" periods 
in/overlapping a run, the conditions system throws an exception which is 
not caught in the event flagger code.

This was fixed in trunk, but too late for the pass2 release.

If I understand this problem, it only affects two types of runs:

1. runs taken before 5/5/15, when SVT HV was added to MYA (up to 5387).

2. runs where SVT bias was never on - mostly junk runs, but I think there 
are a few ECal pedestal/calib runs in this category (5402, 5745, 5747, 
5748).

I don't think SVT people care much about any of these runs. But ECal 
probably cares.

I could apply the necessary fix to the 5.4.0 release, and the patched jar 
could be used to reprocess these runs.

On Sat, 19 Sep 2015, Nathan Baltzell wrote:

> Many failures may have been related to this error:
> No conditions were found with key: svt_bias_constants
>
> Here's a list of runs with that log message:
> /work/hallb/hps/data/engrun2015/pass2fail/svt_bias_constants_runs.txt
>
> -Nathan
>
> ########################################################################
> Use REPLY-ALL to reply to list
>
> To unsubscribe from the HPS-SOFTWARE list, click the following link:
> https://listserv.slac.stanford.edu/cgi-bin/wa?SUBED1=HPS-SOFTWARE&A=1
>

########################################################################
Use REPLY-ALL to reply to list

To unsubscribe from the HPS-SOFTWARE list, click the following link:
https://listserv.slac.stanford.edu/cgi-bin/wa?SUBED1=HPS-SOFTWARE&A=1