The jobs still fail.

It's definitely a problem with the schema directory.


I manage to run it interactively after sourcing:

bash -c 'source ${slic_dir}/init_ilcsoft.sh; exec csh'


where the paths are set using a bash script run from a csh shell (as of the slic/HEAD revision), but this never caused a problem before.


So it can connect to the url when running interactively from ifarm (somehow), but not from a submitted job. It used to be able to.


From: Maurik Holtrop <[log in to unmask]>
Sent: Friday, June 3, 2016 8:14:31 AM
To: Jeremy I. McCormick
Cc: Bradley T Yale; Rafayel Paremuzyan; HPS Software
Subject: Re: XML error affecting SLIC
 
Hi Jeremy,

Is there a way to just turn off schema validation?
It is not like we really need that, and it makes for one more thing that you need to take care of when you are running on a farm, or one more thing that can fail your jobs.

Best,
Maurik


On Jun 2, 2016, at 5:36 PM, McCormick, Jeremy I. <[log in to unmask]> wrote:

These types of schema errors typically happen if SLIC cannot access the URL for the XSD file it needs to download for validating the XML files.  So that suggests a farm/JLAB network hiccup when the job ran.

You may also set the GDML_SCHEMA_DIR variable to a directory containing all the XSD files that are needed which is covered here.

https://confluence.slac.stanford.edu/display/ilc/How+can+I+make+SLIC+look+for+XML+schemas+in+a+local+directory

Or just try the job again....

-----Original Message-----
From: [log in to unmask] [mailto:[log in to unmask]] On Behalf Of Bradley T Yale
Sent: Thursday, June 02, 2016 10:07 AM
To: Rafayel Paremuzyan; hps-software
Subject: Re: XML error affecting SLIC

No jar. SLIC doesn't need one.


It only depends on things like the .lcdd xml file, but the one used is found in the hps-soft/detector-data/... directory.

I'll keep troubleshooting to see if it was farm-related.





________________________________

From: Rafayel Paremuzyan <[log in to unmask]>
Sent: Thursday, June 2, 2016 10:22:09 AM
To: Bradley T Yale; [log in to unmask]
Subject: Re: XML error affecting SLIC 

Hi Brad,

not sure if that is the cause,
but which JAR are you using? hps-distribution-bin.jar, or some specific snapshot or release.
Yesterday around 16:20 I changed hps-distribution-bin.jar to point the 3.9 release, to start the test pass0

Rafo



On 02/06/2016 02:44, Bradley T Yale wrote:


Does anyone know what the following error is about?

It is apparently xml-related, and affects running SLIC:



"fatal error:  systemId: http://www.w3.org/TR/html4/strict.dtd <http://www.w3.org/TR/html4/strict.dtd>  line: 1 column: 3
markup declaration expected"

"fatal error:  systemId: /u/group/hps/hps_soft/detector-data/detectors/HPS-EngRun2015-Nominal-v4-4-fieldmap/HPS-EngRun2015-Nominal-v4-4-fieldmap.lcdd line: 2 column: 189

fatal error during schema scan"

This then causes Geant4 to crash in the standard way.
The same script used (/u/group/hps/production/mc/EngRun2015Scripts/slic/wab-beam-tri_100.xml) worked as of May 18-19, and others using the same detector worked early this week. Did something change very recently that might affect this? Like around the time of the release?

-Bradley



________________________________


Use REPLY-ALL to reply to list

To unsubscribe from the HPS-SOFTWARE list, click the following link:
https://listserv.slac.stanford.edu/cgi-bin/wa?SUBED1=HPS-SOFTWARE&A=1 



________________________________

Use REPLY-ALL to reply to list

To unsubscribe from the HPS-SOFTWARE list, click the following link:
https://listserv.slac.stanford.edu/cgi-bin/wa?SUBED1=HPS-SOFTWARE&A=1 

########################################################################
Use REPLY-ALL to reply to list

To unsubscribe from the HPS-SOFTWARE list, click the following link:
https://listserv.slac.stanford.edu/cgi-bin/wa?SUBED1=HPS-SOFTWARE&A=1



Use REPLY-ALL to reply to list

To unsubscribe from the HPS-SOFTWARE list, click the following link:
https://listserv.slac.stanford.edu/cgi-bin/wa?SUBED1=HPS-SOFTWARE&A=1