HPS-SOFTWARE Archives

Software for the Heavy Photon Search Experiment

HPS-SOFTWARE@LISTSERV.SLAC.STANFORD.EDU

Options: Use Forum View

Use Monospaced Font
Show Text Part by Default
Show All Mail Headers

Message: [<< First] [< Prev] [Next >] [Last >>]
Topic: [<< First] [< Prev] [Next >] [Last >>]
Author: [<< First] [< Prev] [Next >] [Last >>]

Print Reply
Subject:
From:
Sho Uemura <[log in to unmask]>
Reply To:
Software for the Heavy Photon Search Experiment <[log in to unmask]>
Date:
Tue, 9 Sep 2014 07:53:36 -0700
Content-Type:
TEXT/PLAIN
Parts/Attachments:
TEXT/PLAIN (60 lines)
lcsim needs to be built locally right now because there were changes made 
over the weekend to org.lcsim.detector.tracker.silicon.HpsSiSensor, and 
for some reason those changes are not in the lcsim snapshot that Maven 
uses in the build.

On Tue, 9 Sep 2014, Graf, Norman A. wrote:

> Hello Mikhail,
> I am glad to hear that you successfully updated your software
> installations. We look forward to your contributions.
>
> I will review the hps-java installation instructions to clarify the
> issue you bring up regarding the dependence on lcsim.
> Installing and updating the lcsim software packages is strictly
> only a necessity if you are doing active development on the
> svn head version. But since so many of you are working on the
> leading edge it would be good to make this dependence
> more clear.
> Norman
> ________________________________________
> From: [log in to unmask] <[log in to unmask]>
> Sent: Tuesday, September 9, 2014 1:48 AM
> To: Graf, Norman A.; Omar Moreno
> Cc: hps-software
> Subject: Re: build issues
>
> Dear Norman and Omar,
>
> thanks a lot, now I got both packages successfully compiled.
>
> In case of the HPS-Java, I was missing the "lcsim" package (there was an
> old version on disk). Somehow, it is not explained well on the
> installation instruction webpage that one does have to install "lcsim".
> For a new person reading your documentation it looks like the HPS-Java
> is a "version" of lcsim for a particular detector...
>
> As far slic is concerned, apparently my "ilcsoft-install" script
> downloaded incomplete LCDD package or cancelled a part of it afterwards
> (no idea how it could happen). Manual download with:
>
> svn co svn://svn.freehep.org/lcdet/projects/lcdd/tags/v03-03-04/trunk lcdd
>
> resolved the issue.
>
> Best Regards,
>                 Mikhail.
>
> ########################################################################
> Use REPLY-ALL to reply to list
>
> To unsubscribe from the HPS-SOFTWARE list, click the following link:
> https://listserv.slac.stanford.edu/cgi-bin/wa?SUBED1=HPS-SOFTWARE&A=1
>

########################################################################
Use REPLY-ALL to reply to list

To unsubscribe from the HPS-SOFTWARE list, click the following link:
https://listserv.slac.stanford.edu/cgi-bin/wa?SUBED1=HPS-SOFTWARE&A=1

ATOM RSS1 RSS2