XROOTD-L Archives

Support use of xrootd by HEP experiments

XROOTD-L@LISTSERV.SLAC.STANFORD.EDU

Options: Use Forum View

Use Monospaced Font
Show Text Part by Default
Show All Mail Headers

Message: [<< First] [< Prev] [Next >] [Last >>]
Topic: [<< First] [< Prev] [Next >] [Last >>]
Author: [<< First] [< Prev] [Next >] [Last >>]

Print Reply
Subject:
From:
Gerardo Ganis <[log in to unmask]>
Date:
10 Nov 2004 17:53:17 +0100 (CET)Wed, 10 Nov 2004 17:53:17 +0100 (CET)
Content-Type:
TEXT/PLAIN
Parts/Attachments:
TEXT/PLAIN (98 lines)


  Hi,

  I have just committed in CVS a patch to process all the PERL
  related stuff in configure (check of version, definition of 
  relevant variables). This should eliminate all the warnings 
  observed by Pete and Alvise.

  There are two additional options to configure:

     --enable-perlint  

                     to enable the compilation of the perl admin
                     interface

     --with-perl=<path_to_perl_5.8> 

                     to force use of a specific perl executable;
                     the perl wrapper requires v 5.8 or higher.

  By default the interface is not built.  

  Gerri  
  

On Tue, 9 Nov 2004, Peter Elmer wrote:

>   Yes, this problem is known: 
> 
>   http://www.slac.stanford.edu/cgi-bin/lwgate/XROOTD-L/archives/xrootd-l.200411/date/article-14.html
> 
> The plan is to resolve it using ./configure, but we didn't quite get that
> done for this release. It shouldn't stop the build, even if you do get the
> complaints. They only matter for the perl wrapper for the admin stuff.
> 

  



> 
> On Tue, Nov 09, 2004 at 05:02:59PM +0100, Alvise Dorigo wrote:
> > I tried to compile it but I get the following error related to wrong perl 
> > path:
> > 
> > ...
> > Compiling XrdXrootdXeq.cc
> > Creating executable ../../bin/i386_linux26/xrootd
> > Make XrdXrootd done.
> > Making client component...
> > make[2]: perl5.8: Command not found
> > make[2]: perl5.8: Command not found
> > make[3]: perl5.8: Command not found
> > make[3]: perl5.8: Command not found
> > make[4]: perl5.8: Command not found
> > make[4]: perl5.8: Command not found
> > Compiling XrdClientAbs.cc
> > Compiling XrdClient.cc
> > ...
> > 
> > maybethe 'configure' should resolve the correct perl path, shouldn't it ?
> > 
> >  Alvise
> > 
> > On Tuesday 09 November 2004 16:29, Peter Elmer wrote:
> > >   Hi All,
> > >
> > >   There is now a new (development) xrootd version 20041109-0606. It
> > > contains all of the latest posix-client fixes from Fabrizio (many coming
> > > from the tests of the output buffer for skimming at SLAC). There are also
> > > fixes for MacOSX (it builds, although I've not yet made a binary download
> > > for it) plus a bunch of changes from Andy (make "wait" the default for the
> > > olbd, etc.) including some requested by Gregory. There is no strong reason
> > > to try to use this build for "production" work, but testing is welcome.
> > >
> > >   For the full set of changes and links to rpms/tarballs to download see
> > > the the xrootd web page and/or version history:
> > >
> > >    http://xrootd.slac.stanford.edu
> > >    http://xrootd.slac.stanford.edu/xrootd.History
> > >
> > > Let us know if there are problems.
> > >
> > >                                  thanks,
> > >                                    Pete
> 
> 
> 
> -------------------------------------------------------------------------
> Peter Elmer     E-mail: [log in to unmask]      Phone: +41 (22) 767-4644
> Address: CERN Division PPE, Bat. 32 2C-14, CH-1211 Geneva 23, Switzerland
> -------------------------------------------------------------------------
> 




ATOM RSS1 RSS2